iview 2.6.0版本定制主题遇到的问题及解决方法

软件版本:

Node.js v8.9.0

npm 5.5.1

iView 2.6.0

vue-cli 2.9.1

项目创建:

用vue-cli创建一个webpack的Vue项目:

使用npm完成基本安装后,通过npm命令安装iVIew:

文档配置完成后在src/components/HelloWorld.vue随便写一个iView的component:

然后遵循文档的定制主题的内容进行定制操作,关于webpack工程定制主题,文档是这么说的:

这里文档中有几个文档中没说到的问题,首先需要安装less和less-loader两个组件

然后参考gijo-varghese的回答在build/webpack.base.conf.js中的extensions

需要增加一个.less

然后主题就修改成功了:

 

 

 

iview 2.6.0版本定制主题遇到的问题及解决方法》上有7条评论

茗血进行回复 取消回复

电子邮件地址不会被公开。